Delete2Archive for macOS 10.12 Sierra

17 October 2016Apple

In September, Apple released macOS 10.12 Sierra. Due to some changes to the way Mail.app handled plugins, it unfortunately took me much longer to update Delete2Archive than I would have liked. After a month of searching and testing I was finally able to identify the compatibility issue and now have a version of Delete2Archive that is compatible with macOS Sierra.

However, I would strongly reinforce my prior suggestions that you try to get Mail.app working natively to archive your messages without the need of this plugin as Mail.app has come a long way since macOS 10.9 Mavericks in terms of Gmail support and I have not used Delete2Archive personally since macOS 10.9.2. In macOS 10.12 Sierra, there are now specific settings under Preferences > Accounts > Mailbox Behaviors that allow you to map your Gmail folders to their Mail.app equivalents, including the Archive mailbox. Please give it a try before downloading the latest version of Delete2Archive.

For those that still legitimately need the plugin, follow the installation instructions and download the new version of the plugin from the Delete2Archive page.